amc3
Tecnologia

Veja se seu WhatsApp está seguro de vulnerabilidade grave

.

25/11/2019 14h23
Por: Clairton Borba

O WhatsApp passa por uma investigação de segurança após problemas com um arquivo no formato MP4, que permitia que cirbercriminosos obtivessem acesso ao celular de usuários. Agora, o Facebook emitiu um aviso de segurança para os usuários do aplicativo indicando como se proteger. De acordo com a nota, para se proteger completamente da vulnerabilidade, basta atualizar o app para a versão mais recente. Isso porque, de acordo com o Facebook, a falha já foi corrigida pela rede social.

No Android, o usuário deve verificar se em seu dispositivo a versão 2.19.274 do WhatsApp está instalada. Para isso, basta acessar a aba de "Configurações", em seguida "Ajuda", e "Dados do aplicativo".

Para iOS, a versão mais recente e livre da ameaça é a 2.19.100. Para verificar a versão do aplicativo nos dispositivos Apple, o caminho é semelhante: basta entrar em "Configurações" e, em seguida, na opção "Ajuda". Dentro desse menu, será possível verificar a versão do aplicativo. Além disso, como a vulnerabilidade de segurança também afeta a versão do WhatsApp Enterprise Client anterior à 2.25.3 e do WhatsApp para Windows anterior à 2.18.368, é altamente recomendado que todos os usuários do WhatsApp atualizem seu aplicativo.

A falha de segurança 

A vulnerabilidade de segurança, batizada de CVE-2019-11931, é um estouro de "buffer" que envolve o envio de um arquivo MP4 por um remetente desconhecido com o objetivo de infectar o aparelho das vítimas. O arquivo de vídeo, aparentemente inofensivo, ao ser reproduzido, dava aos criminosos a autorização para que códigos maliciosos fossem executados em segundo plano. Tudo isso para obter controle total sobre o telefone dos usuários.

* O conteúdo de cada comentário é de responsabilidade de quem realizá-lo. Nos reservamos ao direito de reprovar ou eliminar comentários em desacordo com o propósito do site ou com palavras ofensivas.